Acronis Backup Console

Resolved
Degraded performance
Started over 2 years ago Lasted 15 minutes

Affected

Global
Acronis Cyber Backup Cloud - Frankfurt DE
Updates
  • Resolved
    Resolved

    The issues with the Acronis console are resolved. If you experience any issues please contact us by email at support@snel.com.

  • Investigating
    Investigating

    We would like to inform you that there is currently an issue with the Acronis Backup, some customers might be unable to reach their Console.