Show current status

[Resolved] Acronis Backup Cloud

Started on February 18, 2020 at 07:51:00. Resolved after less than a minute

Affected

Acronis Cyber Backup Cloud - Frankfurt DE
  • Resolved
    February 18, 2020 at 07:51:00  –  

    Incident started: 04:11 CET Incident resolved: 04:29 CET Service impact: Some customers might be unable to reach Acronis Backup Console, Acronis Files Cloud and Acronis Web Restore.

    If you still experience any issues with Acronis, please send an email to support@snel.com