Show current status

[Resolved] Partial outage Snel cloud platform

Started on February 16, 2020 at 14:08:00. Resolved after less than a minute

Affected

Cloud VPS platform
  • Resolved
    February 16, 2020 at 14:08:00  –  

    Currently we're experiencing a partial outage on our Cloud platform. We're investigating the issue.