Show current status

[Resolved] SMTP Relay

Started on January 14, 2020 at 11:36:00. Resolved after less than a minute

Affected

Snel.com network infrastructure
  • Resolved
    January 14, 2020 at 11:36:00  –  

    There is an identified issue with our outgoing email provider SpamExperts that is affecting performance. SpamExperts is currently investigating this issue.