Show current status

[Resolved] Issues with Control-Panel Server Cloud Platform

Started on April 3, 2018 at 14:53:00. Resolved after less than a minute

Affected

Cloud VPS platform
  • Resolved
    April 3, 2018 at 14:53:00  –  

    FIXED: Currently we experience some issues with our Control-Panel server. This does not affect the availability of the virtual servers but does affect reinstalls and backups.