Snel.com - Acronis Cyber Cloud – Incident details

Acronis Cyber Cloud

Resolved
Operational
Started about 3 years agoLasted about 1 hour

Affected

Global

Operational from 11:30 AM to 12:55 PM

Acronis Cyber Backup Cloud - Frankfurt DE

Operational from 11:30 AM to 12:55 PM

Updates
  • Resolved
    Resolved

    We are pleased to inform you that Acronis Cyber Cloud in the EU2 data center is fully functional now, all services are up and running.

  • Investigating
    Investigating

    At the moment the Acronis Cyber Backup Console is not available, their development team is investigating this issue.